Skip to content
You are reading the Teku development version documentation and some features may not be available in the stable release. You can switch to the stable version using the version box at the bottom of the screen.

Updated on November 12, 2020

Install binary distribution

Linux / Unix / macOS / Windows

Prerequisites

Attention

Teku requires Java 11+ to compile; earlier versions are not supported.

Install from packaged binaries

Download the Teku packaged binaries.

Unpack the downloaded files and change into the teku-<release> directory.

Display Teku command line help to confirm installation:

./bin/teku --help
bin\teku --help

macOS with Homebrew

Prerequisites

Important

Teku requires Java 11+ to run. Earlier versions are not supported. You can install Java using brew cask install adoptopenjdk. Alternatively, you can manually install the Java JDK.

Install (or upgrade) using Homebrew

To install Teku using Homebrew:

brew tap ConsenSys/teku
brew install teku

To upgrade Teku using Homebrew:

brew tap ConsenSys/teku
brew upgrade teku

To display the Teku version and confirm installation:

teku --version
Questions or feedback? You can discuss issues and obtain free support on Teku Discord channel.
For paid professional support by Consensys, contact us at quorum@consensys.net